Meio Bit » Baú » Indústria » Próxima geração do Symbian será incompatível com apps do S60

Próxima geração do Symbian será incompatível com apps do S60

08/08/2009 às 14:07

s60-apps-08082009 Enquanto esperamos ansiosos por Windows 7 e Snow Leopard, Microsoft e Apple, ou ao menos uma pequena parte delas, já se preocupa com os sucessores dos sucessores. É normal. O mesmo ocorre com quem mantém sistemas operacionais para smartphones, como a Symbian Foundation.

Em entrevista ao blog TamsS60, David Wood, da fundação, revelou algumas informações sobre o Symbian^4, próxima geração do sistema que equipa todos os smartphones Nokia e alguns concorrentes. A bomba é a seguinte: não haverá retrocompatibilidade entre o novo Symbian e o atual S60 (Symbian^3)!

O motivo é a mudança no sistema de APIs predominante do sistema. Os planos são descontinuar o conjunto de APIs S60 Avkon, usada no desenho das interfaces dos aplicativos, e partir para as APIs Qt, que, segundo Wood, são mais produtivas e elegantes, e serão muito boas para a comunidade. Outras APIs públicas, especialmente as para middleware e porções internas de aplicativos, continuarão suportadas.

Há salvação? A saída, talvez, seja a inclusão de um emulador de S60, o que permitiria rodar sua gigantesca biblioteca de aplicativos enquanto esses não são portados para a nova versão. A Palm, por exemplo, também quebrou a retrocompatibilidade com o webOS, que equipa o Pre, mas contratou uma third party para desenvolver um emulador que roda aplicativos antigos no novíssimo sistema. Nos desktops, a Apple é outra que fez algo parecido na transição do Mac OS 9 para o Mac OS X, o Rosetta.

Fonte: Download Squad.

relacionados


Comentários