Meio Bit » Arquivos » Software » Go PHP 5

Go PHP 5

06/07/2007 às 23:48

Por diversos motivos, o PHP 5 nunca emplacou.

Apesar dos avanços que a nova versão trouxe, ela não possui compatibilidade total com as verões anteriores.

Para uma empresa de hospedagem, ou ela mantém as duas versões funcionando, ou mantém só a versão 4, caso contrário um número enorme de sites parará de funcionar.

Manter as duas verões funcionando implica em um custo extra no consumo de recursos e soluções customizadas.

Assim, a adoção vem sendo postergada.

Mas os desenvolvedores querem mudar isso para poder aproveitar as vantagens da versão 5 do PHP.

Uma das iniciativas, é o Go PHP 5, onde um contador mostra 213 dias para a adoção do PHP 5.

Vários projetos estão listados na iniciativa, entre eles o Drupal, usado pelo Meio Bit e o phpMyAdmin, que é praticamente um padrão nos servidores que usam cPanel.

Na lista de desenvolvimento do WordPress as opiniões estão divididas, parte dos desenvolvedores deseja abandonar o PHP 4 o mais rápido possível, outra parte, deseja deixar para a versão 3.0.

Mas, esses scripts, em sua maioria, não são possuem força suficiente para mudar o mercado.

A grande exceção é, justamente, o phpMyAdmin.

Praticamente, todos os servidores usam o phpMySql como gerenciador de bancos de dados, no momento que ele deixar de suportar o PHP 4, a mudança será obrigatória para a grande maioria das hospedagem.

Em função do impacto do phpMyAdmin, seria interessante que o foco maior dessa iniciativa fosse no mesmo, pois mudar os demais seria pouco eficiente.

O time do phpMyAdmin promete que passará a funcionar somente com o PHP 5 a partir do dia 5 de fevereiro de 2008, que é a data marcada no contador.

Será essa a data do fim de 8 anos de bons serviços?

relacionados


Comentários